第一次启动

  第一次启动时的界面：
  操作说明：
    第一次启动水晶排课后，可以看到如上图的界面。上图因为水晶排课刚安装而基本数据未录入，所以大多数按钮呈灰色的不可用状态。
    基本录入顺序为：“ 1 设置班级→ 2 设置课时→ 3 科目节数→ 4 教师任课→ 5 开始排课”。上一个环节录入完毕，下一个环节的功能就开放，完成“ 5 开始排课”后就可以打开课程表了。完成后主界面请看...
  图解：
        1 　点击录入数据第一步：设置班级。详情请看...
       2 　点击录入数据第二步：设置课时。详情请看...
       3 　点击录入数据第三步：设置科目节数。详情请看...
       4 　点击录入数据第四步：设置教师任课。详情请看...
       5 　点击开始自动排课。详情请看...
       6 　点击弹出打开课程表菜单，如下图。选择课程表打开，可以进行手工调动及打印。详情请看...

       7 　设置公共场室。详情请看...
       8 　设置合班课。详情请看...
       9 　预排课程，这是对 3 中的科目预排的整合设置。详情请看...
       10 　自定义排课条件，该功能跟 5 中的自定义排课条件功能是一样的。详情请看...
       11 　反导入总课程表。为防误操作，当完成排课后，此处会自动隐藏，但鼠标移上去时还会显示出来。
            详情请看...
       12 　点击后会弹出包含着当前界面的基本功能菜单。（在其余窗口也一样，不再重复。）
       13 　关闭水晶排课。
       14 　显示当前界面的相关帮助，快捷键是“ F1 ”。（在其余窗口也一样，不再重复。）
       15 　显示怎么购买水晶排课正式版，里面有另有详细说明。（查看免费版和正式版的区别）
       16 　在线升级：点击后会检查是否有新版本，可以选择是否升级为最新版。
            （推荐升级！若网络环境不好，可点 http://myzan.cn/upfile/newver10.exe下载升级包。）
       17 　建立、切换、修改登录的用户。（“浏览者”不能修改数据，“操作员”拥有所有权限。）
       18 　显示正使用着的版本。（查看免费版和正式版的区别）
       19 　水晶排课的数据库路径。
       20 　打开备份文件，恢复数据。恢复后现有数据就会被这个打开的备份文件所覆盖，切记不能弄错。
       21 　将现有数据另存为一个扩展名为“.yqd”的文件。当数据意外丢失时，可以用 20 的方法恢复数据。
       22 　临时调代课功能：用于学期中途调代课。详情请看...
       23 　导出工作量表格：可以自动计算出指定时间段内，教师的任课节数。详情请看...
       24 　监考表功能：可以自动排监考表，导出EXCEL监考表。详情请看...
       25 　查询基本数据。
       26 　查询空闲教师。详情请看...
       27 　显示、导出教师课程分布。


录入完成后的主界面

<<返回
  录入完成后的主界面：

  录入完成后才显示的5个“清除”按钮：
   1 　清除班级信息。（会同时清空：课时设置、课程节数、任课信息、课程表以及预排设置。）
   2 　清除课节信息。（会同时清空所有预设的排课条件。）
   3 　清除科目节数。（会同时清空所有任课信息、课程表、以及科目的所有预排设置。）
   4 　清除教师及任课信息。（清除教师、任课信息后，会同时清空所有课程表，以及教师的所有预排设置。）
   5 　清空课程表。

<<返回


基本录入流程

 基本录入流程为：设置班级、设置课时、设置科目节数、设置教师任课、开始排课、手工调课。


设置班级

  设置班级：
  操作说明：
    基本信息录入第一环节：设置班级。
    添加班级的步骤为：新增年级组 3 →填年级组名称→新增班级 5 →填班级名称。在修改年级、班级名称时，可以通过键盘的方向键控制光标的位置。这里有一个一步到位的方法，就是点击 8 所指按钮，快速导入EXCEL数据。
    注意，在其他信息已录入的情况下回到这里修改班级时，不要随意删除班级，因为班级删除后其相关数据也会删除。而修改班级或年级名称时则不用怕，系统只会将名称修改过来，并不影响其他数据。上图是在班级未添加时进入的界面，下面只有一大片空白，完成后界面请看...
  图解：
        1 　返回主界面。
       2 　保存数据，快捷键是“ Ctrl ＋ S ”，在其他步骤也一样。
       3 　新增年级组，按下后会弹出下面这个窗口。设置好年级数再确定就可以了。

       4 　自动填充年级名称，按下后会弹出如下图的菜单供选择，可以自动填充常见的年级名称。
           当然，你也可以点击相应的年级名手工修改。

       5 　新增班级：按下后会弹出如右图这样的菜单要求你选择增至哪个年级和设置班级数量。
           点“确定”之后，班级就会添加进去并显示在下方。

       6 　自动填充班级名称，按下后会弹出下面的窗口。可以按照规则填充班级名称。

       7 　取消 6 的上一次班级名称的自动填充。
       8 　从EXCEL导入班级。EXCEL表每个竖列为一个年级组。第一横行填年级名称，从第二横行开始填班级名称。


添加班级后的班级界面

<<返回
  添加班级后的班级界面：

<<返回


设置课时

  设置课时：
  操作说明：
    基本信息录入第二环节：设置课时。这里主要是设置上课天数、每天节数。
    一般操作步骤为：设置上课天数 4 →设置每天节数 5 →设置免任课位置 8 。完成后如果需要，再设置节次时间 6 和公共时段 7 。课程表的彩色方块分别为：■蓝色代表上午、■绿色代表下午、■橙色代表晚上、■红色代表免任课。
    要注意的是， 8 处所指的免任课位置，当设置为“无课”时，该位置在打印时为空白；当设置为其他文字时就会打印出来。尽管这样，在打印时无论是不是空白，这些设置为免任课■的位置就一定不会排课。
    计算排课节数的公式：本班排课节总数＝（上午节数＋下午节数＋晚上节数）×上课天数－本班免任课节数
  图解：
        1 　返回主界面。
       2 　保存数据，快捷键是“ Ctrl ＋ S ”，在其他步骤也一样。
       3 　设置免任课时的针对范围。默认情况下是选择“全校”，表示设置免任课时是全校均有效的。
           若需精确年级(或班级)进行免任课的设置，只需先选择相应的年级(或班级)后再设置就可以了。
       4 　选择哪一天需要上课，需要上课的就在前面打勾。
       5 　设置每天的上课节数。分别是上午几节、下午几节、晚上几节。
       6 　填写节次时间。该功能即使不填写也不影响排课，但最好填写，这样课程表会更加美观。其设置窗口如下图：

       7 　填写公共时段。该功能与排课无关，公共时段不影响排课，可依据各自学校的习惯设置。其设置窗口如下图：
           当设置“于第0节后面添加”时，该公共时段就会添加在第1节课前面。
           每两节课的间隙可以设置一个公共时段。完成后点“关闭”。

       8 　设置免任课位置，方法为：点击课节方块或右键选择免任课类型，同时该方格会变成红色■，表明该位置为“免任课”。再点一次会恢复为正常课节。当直接点击或选择“无课”时，虽然红色方格上会显示“无课”两字，但实际打印在课程表上时是空白的。而设置为自习、劳动、教研活动等名称或自定义其它名称时，这些名称就会打印在课程表上。下图是选择菜单项“其它名称..”后显示的窗口，可以自定义需要打印在免任课位置的文字。（注意：就算有打印文字，这个位置也跟“无课”一样属于不排课的位置，唯一的区别就是有没有打印文字。）


科目节数

  科目节数：
  操作说明：
    基本信息录入第三环节：科目节数。这个环节的工作是添加科目、填写科目的名称和简称、设置科目在各级的节数，如果有需要，还可以设置科目的场室限制（或同时上课限制），两节连堂次数，以及对科目的预设。
    一般操作步骤为：添加科目空行 3 →填写科目全称及简称 10 →填写科目节数 11 →其他设置 12 / 13 / 14 。添加科目 10 及设置节数 11 可从EXCEL直接导入 8 。
    注意： 15 处上面的“节数合计”不能超出下面的“课时容量”。“课时容量”指在第二环节中设置的可排节数总和，当“节数合计”超出容量时，会造成个别课程没位置排。
  图解：
        1 　返回主界面。
       2 　保存数据，快捷键是“ Ctrl ＋ S ”，在其他步骤也一样。
       3 　添加科目空行。若手工录入，建议操作时先把所有空行都添加完毕再录入，避免不断地在键盘和鼠标间来回换手。
       4 　删除科目。（注意：当该科目的其他信息已录入，删除后该科目的相关信息也会同步删除。）
       5 　将科目上移一行。点击左边的“ [image] ”按钮可移至最上面。也可以直接用鼠标拖动科目来调整顺序。
       6 　将科目下移一行。点击右边的“ [image] ”按钮可移至最下面。也可以直接用鼠标拖动科目来调整顺序。
       7 　自动填充科目简称。可以选择用“科目首字”和“科目末字”来填充。（简称也可手工修改）
       8 　从EXCEL导入数据，点击后会显示表模的格式说明。
           要注意的是如果同年级各班节数不同时，将各班的节数用半角逗号隔开就可以了，如“3,2,3,3,3”。
       9 　将科目名称及节数导出至EXCEL。与 8 的作用相反。
       10 　这两列是科目的全称和简称，点击相应方格可以直接录入。可以用方向键←↑→↓控制光标位置。
       11 　录入科目在各年级上的节数。如果需要精确到班，点光标右边的按钮就会弹出该年级的所有班级了。如下图：

       12 　设置公共场室限制，有两种设置方式：设置公共场室、设置同科上限。如下图，该列头可弹出菜单供选择。
            当选择公共场室进行限制时，需要先建立公共场室，再选择相应的场室。
            当选择同科上限时，只需录入上限数字就可以了。如：录入“2”，表示该科全校同时只能上2节课。

       13 　设置两节连堂的次数。当需强制设置连堂的次数时，可以在这里设置。但若非一定要连堂，建议不要设置此项。
       14 　设置科目预排，鼠标点击该列时，会出现如下图的三个按钮：设置(请看详细设置方法..)、复制、粘贴。

       15 　第一行是各班的课程节数合计，
            第二行是各班的课时容量。(课时容量=上课天数×每天节数－该班的免任课节数) (详情看设置课时..)
            所以第一行的合计数一定不能超过第二行，不然超出的课程就会没地方排。如下图，在保存时就会预警。


教师任课

  教师任课（新版本任课视角）：
  操作说明：(11.0版以后新加入的任课录入方式。)
    基本信息录入第四环节：教师任课（新版）。这个环节的工作是设置教师名单，分配任课，如果需要还可以对教师的课节进行预设。
    基本操作步骤为：点击任课方块 6 →选择教师后点击按钮 9 （若未添加教师，请先添加）。
    建议先点击 3 将教师名单完成，再接着分配任课。
    要点一：当选中一个教师后，会自动将对应的课程全部分配给这个教师。当某处任课需要两个或以上教师分担时，必须在选择第一个教师后，点击 8 修改节数，这样才可以接着添加另外的教师。
    要点二：在课程表已排的情况下，若教师或任课改变，那么相关的课程就会下放到课程表的暂放区。当任课改变时，只需直接修改任课。保存后打开课程表，会发现所有改动过的任课都被下放到暂放区，将暂放区的课程拖回课程表就可以了。
    诀窍一：当一个教师任多处任课时，可以用复制功能快速完成。方法是右键点击已设置好该教师的任课方块，如 6 处，弹出菜单选择“复制教师”，会发现鼠标后面带了一个包含教师名称的小尾巴。这时点击左键可粘贴教师，右键取消复制模式。
    诀窍二：点击 1 可在新、旧版录入视角中切换。
  图解：
        1 　切换至老版本界面。
       2 　任课表格中是否显示节数。
       3 　显示教师名单，可以增删教师，修改名称，设置教师预设（参照科目预设）。
       4 　从EXCEL导入任课信息。（EXCEL导入教师名单的功能已移至教师名单窗口）
       5 　导出任课数据，生成EXCEL文件。（导出每周工作量的功能移至工作量统计窗口）
       6 　任课方块，点击之后可以设置任课教师。
       7 　清空所选任课信息。
       8 　修改教师的任课节数。
       9 　选中所选教师，任该处任课。
       10 　从EXCEL导入教师名单。


教师任课

  教师任课（老版本教师视角）：
  操作说明：
    基本信息录入第四环节：教师任课。这个环节的工作是添加教师，再将课程任课分配给教师，如果需要还可以对教师的课节进行预设。
    一般操作步骤为：添加教师空行 3 →填写教师全称及简称 9 →分配任课给教师 5 / 12 →预设 11 。除预设之外其余信息都可以从EXCEL直接导入 7 。
    分配任课给教师时，有两种方法。第一种是批量添加任课 5 ，第二种是直接从右边栏将任课拖给教师 12 。
    注意：在课程表已排的情况下，若教师或任课改变，那么相关的课程就会下放到课程表的暂放区。当任课改变时，只需将任课情况 10 中的课程拖给其他教师，保存后打开课程表，将暂放区中的课程调回课程表就可以了。
  图解：
        1 　返回主界面。
       2 　保存数据，快捷键是“ Ctrl ＋ S ”，在其他步骤也一样。
       3 　添加教师空行、删除教师。
       4 　将教师上移（或下移）一行，也可用鼠标拖动教师来调整顺序。（与调整科目顺序的操作一样）
       5 　批量添加任课。当选中某个教师后，点击该按钮后，会弹出如下图的窗口：

       6 　自动填充教师简称。有下拉菜单可供选择自动填充的方式。（简称也可手工修改）
       7 　从EXCEL导入数据，有“只导入教师名”和“导入教师、任课”两种方式，点选后会显示详细的表模格式。
          注意，当导入任课时，若某个班的某个课程由多位教师分担，EXCEL填写格式为：“教师A,节数,教师B,节数”，
          中间的逗号为半角逗号。如“陈大宇,2,马小明,3”。
       8 　将任课信息导出为EXCEL表格。如下图：

           有两种格式可以导出：第一种是导出为 7 的导入数据；第二种是水晶排课独有的任课表格。

       9 　这两列是教师的全称和简称，点击相应方格可以直接录入。可以用方向键←↑→↓控制光标位置。
       10 　显示该教师任课。点击后会显示编辑该教师任课的按钮，如下图：

            点“添任课”会切换到批量添加任课窗口 5 ；
            点“删任课”会将任课放回右侧的“剩余任课栏 12 ”；
            将任课拖至“剩余任课栏”同样可以起到“删任课”的作用；
            将任课拖给其他教师，任课就会调换给那个教师。

       11 　设置教师预排，鼠标点击该列时，会出现三个按钮：设置、复制、粘贴。设置方式可以参照科目预设。
       12 　右侧显示的是未分配给教师的课程。可以将课程从此处直接拖给教师。


开始排课

  开始排课：
  操作说明：
    此处可以进行自动排课，水晶排课会自动分配课程位置，按所设置规则自动生成最优排列的课程表。
    点击“开始排课 2 ”按钮就可以开始自动排课。如果只想排个别班级，可以在左侧 3 选择。第一次排课之前最好先看一下右侧 5 ～ 9 的排课规则，看看需不需要修改设置。中间 4 是自定义排课条件的设置，详情请看...
  图解：
        1 　返回主界面。
       2 　开始自动排课。水晶排课会根据所设置的预排、自定义条件、排课规则进行自动排课。自动排课中途可以取消。
       3 　选择需要排课的班级，打勾的为已选择。
       4 　设置自定义排课条件。详情请看...
       5 　自动排课强度最好选择“高精度排课”。如果条件太严，可以考虑选择“正常排课”。
       6 　最好选择“尽量一致”。如果选择第二个，在单科节数多的情况下，可能会导致多节课不能排。
       7 　设置教师当天的课尽量分散或集中：（在不影响自定义条件和预排的情况下排得进去才会优先执行此条件）
           第一个选项：当教师在一天当中有多节课时，会尽量将他的课分散到上下午都有。
           第二个选项：当教师在一天当中有多节课时，会尽量将课集中在一个午别完成。
           第三个选项：无所谓，不考虑此条件。
       8 　如果选择第二个选项，就表示一定不让教师上午末节课与下午首节的课连续。
           即教师上午末节有课时，下午首节就一定不能有课。反之，下午首节有课时，上午末节也一定不能有课。
       9 　科目的连堂规则：（注：已在科目设置中设置了“两节连堂次数”的科目不在此设置范围内）
           第一个选项：尽量不连堂，但是如果实在没办法也可以连。
           第二个选项：宁可不排，也不连堂。
           第三个选项：同一天的课尽量连在一起上完。如：当某个班一天内有3节语文，这3节语文就会连在一起上完。


课程表操作

  课程表操作：

（上图为“每天一列”格式，选择 10 处可以改为“每天一行”的格式）
（总课程表式格略有不同，其格式请点此查看...）
  操作说明：
    可以对课程进行手工调动、打印。各类课程表之间可以随意切换显示。鼠标移至 14 区域时，按 F5 可在鼠标所指的班级和教师之间来回切换。
    手工调课的操作步骤：在 4 处选择要调动的班级(教师)→在 14 处和 17 处对课程进行拖动。
    打印课程表的操作方法：点击 9 处可以打开打印窗口，详情请看...
    调课时可随意在各种课程表 3 之间切换。任何一种课表调动后，其他相应课表也会改变过来。完成后记得保存 2 。
    总课程表窗口调课时略有不同，详情请看...
  图解：
       1 　返回主界面。
       2 　保存数据，快捷键是“ Ctrl ＋ S ”，在其他步骤也一样。
       3 　切换显示不同类型的课程表：班级表、教师表、总课程表、总任课表、场室表。
       4 　切换为班级表时，此处可以选择班级。切换为教师表时，用来选择教师。切换为场室表时，用来选择场室。
       5 　显示前一页（快捷键是“ F3 ”）和后一页（快捷键是“ F4 ”）。
       6 　撤消上一步操作（快捷键是“ Ctrl ＋ Z ”）和重做（“ Ctrl ＋ R ”）。
       7 　锁定与解锁课表。可以锁定指定班级或教师的课表，暂时禁止调动。(在总课表上可以全校锁定和解锁。)
       8 　显示，教师及科目的课时分布情况，可导出至EXCEL。
       9 　在班级表、教师表、场室表中，点击后可以选择导出打印课程表或调课通知。
           在总课程表、总任课表中，点击后可以导出打印总课程表或总任课表。
       10 　设置表格的格式：每天一行、每天一列。
       11 　设置课程表的显示内容。
       12 　是否显示拖动时跟随鼠标的小课表。
            当打开时，如下图，小课表显示的是严艺敏老师的课表，黑色的“语”小方块代表正在调动着的语文课。

       13 　设置上图小课表的透明度。
       14 　调课区域。只需用鼠标对课程进行拖放就可以调课。当课节被拖动时，课节方块也会改变颜色，如下图，
            课节拖动时会实时提示是否可以调动的原因。

       15 　这里显示的是与主课表有关联的小课表，如：当主课表显示的是一年1班，这里会显示的就是一年1班所有任课老师的课表；当主课表显示的是严艺敏老师，这里就会显示严艺敏老师任教的所有班级的课表。点击这些小课表可直接切换至相应的课表。
       16 　这里显示着从打开课表后被调动过的班级和教师。点下面的调课通知或 9 处的导出可生成调课通知单。
       17 　课程暂放区：显示未排的课程，也可以从 14 处将课节拖放到这里。
       18 　点击后自动对齐暂放区的课节方块。


打印课程表

  打印窗口(班级表、教师表、场室表)：

  打印效果：


打印总课程表

  打印窗口(总课程表、总任课表)：

  打印效果（导出后对列宽稍作调整）：


打印调课通知

  打印调课通知：

  打印效果：


其他条件设置

 其他条件设置包括：场室设置、合班设置、预排、自定义条件设置等功能。


合班设置

  合班设置：
  操作说明：
    合班课指多个班合并在一起，由一位教师上课的课程。所以必须是同教师、同科目、不同班的课才可以合班。
    操作步骤：先选择教师 1 →勾选需要合班的课 2 →点击合班按钮 4 。完成后右侧的合班课列表 5 会显示出合班课。
    注意：如果课程表已排，点“合班”或“取消合班”后相关课程会自动下放到暂放区，需要手工调上去。
  图解：
        1 　第一步，选择教师。
       2 　第二步，勾选任课。
       3 　此处显示是否可以合班的提示。
       4 　选择教师、任课后，点此处合班。
       5 　全校所有的合班课会显示在此处。
       6 　选择右侧的合班课，再点此按钮可以取消合班。


预排

  预排：
  操作说明：
    预排窗口是对科目预设的整合，作用是一样的，但在预设较多时会更直观。
    操作步骤：选择预排的范围 1 →预排课节 2 。
  图解：
        1 　选择预排的范围，可以选择全校、全级、单个班。
       2 　预排区域，点击后会弹出菜单。
       3 　点设置会弹出如下图的窗口，对课节进行预排（不排、一定排、尽量排）。


科目预设

  科目预设：
  操作说明：
    科目预设窗口用来设置科目在指定位置的一定排、尽量排、不排。
    先选择左边的针对范围，再设置右边的课节。默认选择范围为“全校”，可以精确到各年级或各班。点击课节方块可以在“尽量排→一定排→不排”之间循环，也可以右键选择菜单项。完成后点“确定”。
  图解：
        1 　选择设置的有效范围。
       2 　切换到其他学科进行设置。
       3 　在该范围内点击方块或右键选择菜单进行设置一定排、尽量排、不排。


设置公共场室

  设置公共场室：
  操作说明：
    公共场室设置不是必填项，只有在课程受公共场室限制时才须设置。这里要注意的是“容量”项目，其单位是“班”。比如：“大操场”可以容得下2个班同时上课，那就填“2”，“小音乐室”只容得下1个班，那就填“1”。
    （此处可以通过EXCEL导入，点“从EXCEL导入”后会显示表格的格式。）


自定义排课条件

  自定义排课条件：
  操作说明：
    直接点 1 “添加”按钮会弹出自定义条件添加窗口，双击下方已设置好的自定义条件可以对其进行编辑。
    弹出的自定义条件窗口有五类条件可以设置：时段限制、各天限制、教师互斥、科目互斥、禁止科目相邻。

    条件类型一：时段限制：某些科目（或教师）在整个星期某个时间段的总节数限制，如下图限制“整星期上午固定1节”。

    条件类型二：各天限制：某些科目（或教师）在某天的节数限制。如下图限制“每天固定排1节课”。

    条件类型三：教师互斥：设置两个教师不在同一时间上课。
    条件类型四：科目互斥：设置两个科目不在同一天上课。
    条件类型五：禁止科目相邻：禁止两个科目相邻。如“体育不排于语文前面”。


反导入总课程表

  反导入总课程表：
  操作说明：
    这里提供了从EXCEL格式的总课程表导入数据的功能。因为导入的时候会覆盖原有一些数据，建议先做好数据备份。
    前提：班级信息、课节信息必须先设置好。保证在班级信息中设置了与EXCEL总课表中的要导入的班级匹配的班级名(注意班级名称一定要一样)；保证课节信息一定要与EXCEL总课表一样。
    操作步骤：先“选择EXCEL总课表” 1 →检测通过后点“确定导入” 2 。
    导入过程：选择EXCEL总课表打开后，水晶排课会先检测EXCEL表中是否存在名称匹配的班级，然后再检测课节设置是否相符。科目和教师一定要用全称，如果检查到存在未添加的科目和教师，会显示导入后将自动添加的科目和教师。如果检查到EXCEL总课程表中教师出现冲课情况，会提示冲突并禁止导入，所以本功能不能导入包含“合班课”的总课程表。当存在同名同姓的教师时，一定要自己标记区分开来（如：存在两个“郑友群”，那就把其中的一个“郑友群”改为“郑友群1”）。
    注意：导入后水晶排课会自动建立科目节数、教师任课、课程表等数据，但记得自己填好科目及教师的简称。
  图解：
       1 　打开EXCEL总课表并自动检测，并显示导入的有关信息。
       2 　通过 1 打开检测通过后，点击该按钮后会开始导入总课程表。
       3 　生成空表模作参考，但最好的参考还是一张完整的总课程表，如上学期的总课程表。


其他附加功能

 附加功能包括：临时调代课、工作量、监考表、查询基本数据、查询空闲教师、查询教师课程分布等功能。


查询有课或空闲教师

  查询有课或空闲的教师：

  操作说明：
    点击左边课节方块，显示有课或空闲的教师。当设置多个方块条件时，表示必须同时符合多个条件。如上图，显示星期三第2节有课并且星期四第3节无课的教师。
  图解：
       1 　点击课节方块两次，显示“有课”，表示显示的教师必须于此处有课。
       2 　点击课节方块一次，显示“空闲”，表示显示的教师必须于此处无课。
       3 　该区域显示符合条件的教师。双击教师图标可以查看该教师课表。点“导出名单”可生成EXCEL表格。


临时调代课

  临时调代课：

  操作说明：
    有时需要在学期中间对课程进行一些小改动。比如因某个老师请假而需要进行调代课，但又不想改到学期头排好的课表。这时就可以用此“临时调代课”功能。
    “临时调代课”不会影响原始课表，每一次调代课就是一个“调代课任务”。“调代课任务”可以保存，保存的信息就是课节的调动信息。
    “调代课任务”具有继承性，新建时可以选择在原始课表或其他“调代课任务”的基础上新建。当选择其他任务新建时，就会继承它的调动信息。在开始调代课时各个“调代课任务”之间的继承关系会如“图1”一样直观地显示出来。
    临时调代课操作可以参照课程表操作，除了“代课”功能 11 ，其他基本一样。
  图解：
       1 　这里显示的是已存在的“调代课任务”，可以双击打开。
       2 　选择“调代课任务”的显示方式：流程图显示、列表显示。
       3 　创建“调代课任务”，点击后会显示如下图的显示菜单，可以选择以“原始课表”或“所选任务”为基础。

           以“原始课表”为基础：直接继承自期初课程表，在期初课程表的基础上进行调代课。
           以“所选任务”为基础：继承正选择着的“调代课任务”，以其为基础进行调代课。
          （注意：上一级“调代课任务”或“原始课表”的改动，都会同步改动现有的“调代课任务”。）
       4 　打开所选“调代课任务”，与双击 1 效果相同。
       5 　改变“调代课任务”名称。
       6 　复制“调代课任务”。
       7 　删除“调代课任务”。（若存在下属任务，这些下属任务会自动转为“原始课表”下属。）
       8 　返回水晶排课主界面。
       9 　设定、修改“调代课任务”名称。
       10 　设定“调代课任务”的实际执行期限，并非必要设置。如果不需统计工作量，可忽略此处。
            若正确填写实际执行期限，在计算教师实际工作量时会自动将调代课情况计入。
       11 　选择其他教师代课，点击后会弹出如下图的窗口。


导出工作量

  导出工作量：

  操作说明：
    设置统计期限后，会自动统计出应上课节数、实际上课节数、调代节数，可导出至EXCEL表格。


排监考表

  排监考表：

  操作说明：
    排监考表是水晶排课的一个附加功能，设置考试信息后会自动生成监考表及教师分配表。
    操作步骤：设置考试科目 1 →安排试室 2 →设置规则 4 →设置是否要监考人员 5 →开始自动排监考 3 。
    注意：监考表表格大小受年级、科目影响而变化，导出的EXCEL表格请调整后才打印。
  图解：
       1 　设置各年级的考试科目，点击后会显示如下图窗口：

       2 　安排试室，点击后会显示如下图窗口：

       3 　点击后可自动排监考表。
       4 　点击后可设置监考表安排规则，如下图：

       5 　设置“不监考人员”及“一定要监考人员”。
       6 　显示监考表安排情况，点击后会显示下图菜单：

       7 　显示所有教师的监考课节数。当选中某一教师时，其在 6 处的所监考方块背景会变为红色。


免费版与正式版的区别

水晶排课免费版与正式版的区别
对比项目 | 水晶排课免费版 | 水晶排课正式版
录入修改数据 | √ | √
保存基本数据 | 定时清空 | √
自动排课 | √ | √
保存自动排课结果 | √ | √
保存手工调课结果 |  | √
打印导出课程表 |  | √
监考表及其他日常功能 | √ | √